// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([\w.]+@[\w.]+)|(?:(?:\b|[,/]\s*)(?:whatsapp|viber|wechat))+\b\s*[::]?\s*([()+\d -]+\d)|\bline(?:\sid)?\s*(?:[::]\s*)?@?(\w+)|((?:\+\d+[ -]?)?(?:\(\d+\)[ -]?)?\d[\d -]{5,}\d)").unwrap();
let string = "??5-yr online store ? Real pictures?? ?Mirror Quality ??1:1 ?Whatsapp/Viber +861776345378 ?spikydudewonderland@gmail.com ✈️✈️Worldwide Shipping
Девочки это наша новая страничка.Только копии Lux, искателям дешевых подделок не беспокоить. По всем вопросам viber,whatsapp +79128743333 Лианна
Recruitment Agents????The most powerful manufacturers,we have thebest quality.?Wechat:13255996580??Whatsapp:+8618820784535
? เข้าช้อปทุกวันจ้า? ซื้อกับวี้ได้ของแท้แน่นอนค่า? แบรนด์อื่นสอบถามได้ค่า? ดรีวิว@reviewkayasisshopp? LINE ID : @kux1427k (มี @ ด้วยจ้า)
Menyediakan Kacamata Termurah dengan Kualitas Super
from: Surabaya
Tanya / order :
pin bb : 59f72347
WA/SMS/Call : 082231506095
Line : qurotinayunina
?Brandname Hiend สั่งเมื่อพร้อมโอน?CFห้ามCC?ship world wide ?LINE:@candy_hiend(มี@) candy_hiend@hotmail.com
0532 397 49 40
1-877-958-5211
(38)99937-7007
+12345678
+1234567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}