# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)([\w.]+@[\w.]+)|(?:(?:\b|[,/]\s*)(?:whatsapp|viber|wechat))+\b\s*[::]?\s*([()+\d -]+\d)|\bline(?:\sid)?\s*(?:[::]\s*)?@?(\w+)|((?:\+\d+[ -]?)?(?:\(\d+\)[ -]?)?\d[\d -]{5,}\d)"
test_str = ("??5-yr online store ? Real pictures?? ?Mirror Quality ??1:1 ?Whatsapp/Viber +861776345378 ?spikydudewonderland@gmail.com ✈️✈️Worldwide Shipping\n\n"
"Девочки это наша новая страничка.Только копии Lux, искателям дешевых подделок не беспокоить. По всем вопросам viber,whatsapp +79128743333 Лианна\n\n"
"Recruitment Agents????The most powerful manufacturers,we have thebest quality.?Wechat:13255996580??Whatsapp:+8618820784535\n\n"
"? เข้าช้อปทุกวันจ้า? ซื้อกับวี้ได้ของแท้แน่นอนค่า? แบรนด์อื่นสอบถามได้ค่า? ดรีวิว@reviewkayasisshopp? LINE ID : @kux1427k (มี @ ด้วยจ้า)\n\n"
"Menyediakan Kacamata Termurah dengan Kualitas Super\n"
"from: Surabaya\n"
"Tanya / order : \n"
"pin bb : 59f72347\n"
"WA/SMS/Call : 082231506095\n"
"Line : qurotinayunina\n\n"
"?Brandname Hiend สั่งเมื่อพร้อมโอน?CFห้ามCC?ship world wide ?LINE:@candy_hiend(มี@) candy_hiend@hotmail.com\n\n"
"0532 397 49 40\n"
"1-877-958-5211\n"
"(38)99937-7007\n"
"+12345678\n"
"+1234567")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.