#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(\[(?P<release_group>.+?)\][ ._-]*)?((\[|\().+?(\]|\))[ ._-]*)?(?P<series_name>.+?)[ ._-]+((épisode|episode|part)[ ._-]*)?((E)?(?P<ep_ab_num>\d{1,3}))[\(\)\[\] ._-]+((and.Part.|E)?(?P<extra_ab_ep_num>\d{1,3})[\(\)\[\] ._-]+)?(VOSTFR[\(\)\[\] ._-]*)?((par[ ._-]+Fansub-Resistance)[\(\)\[\] ._-]*)?(((v|V)([0-9]))[\(\)\[\] ._-]*)?(((8|10)(Bits|Bit))[\(\)\[\] ._-]*)?((?P<extra_info>((((FHD|HD|SD)[ ._-])?(\d{3,4}[xip*]+\d{0,4}))|(.*)))[\(\)\[\] ._-]*)?(VOSTFR[\(\)\[\] ._-]*)?((FHD|HD|SD)[\(\)\[\] ._-]*)?(((8|10)(Bits|Bit))[\(\)\[\] ._-]*)?(((v|V)(?P<version>[0-9]))[\(\)\[\] ._-]*)?((?P<crc>\w{8})[\(\)\[\] ._-]*)?.*"
Local $sString = "[Release-Group]_Series_Name_E100-E101_[VOSTFR]_[720p]_[HD]_[8bits]_[V3]_[13245678].mp4" & @CRLF & _
"[Kaerizaki-Fansub]_One_Piece_727_[VOSTFR][HD_1280x720][V2]_[1921E00C].mp4" & @CRLF & _
"[Titania-Fansub]_Fairy_Tail_269-280_[VOSTFR]_[720p]_[1921E00C].mp4" & @CRLF & _
"[ISLAND]One_Piece_726_[VOSTFR]_[V1]_[8bit]_[720p]_[2F7B3FA2].mp4" & @CRLF & _
"Naruto Shippuden 445 VOSTFR par Fansub-Resistance (1280*720) - version MQ" & @CRLF & _
"Dragon Ball Super 015 VOSTFR par Fansub-Resistance (1280x720) - HQ version" & @CRLF & _
"[Mystic.Z-Team].Dragon.Ball.Super.-.épisode.36.VOSTFR.720p" & @CRLF & _
"[Z-Team][DBSuper.pw] Dragon Ball Super - E028 (VOSTFR)(720p AAC)(MP4)" & @CRLF & _
"[SnF] Shokugeki no Souma - 24 VOSTFR [720p][41761760].mkv" & @CRLF & _
"[Y-F] Ao no Kanata no Four Rhythm - 03 Vostfr HD 8bits" & @CRLF & _
"Detective Conan 804 vostfr HD" & @CRLF & _
"Active Raid 04 vostfr [1080p]" & @CRLF & _
"Sekko Boys 04 vostfr [720p]" & @CRLF & _
"Show.Name.E23.Source.Quality.Etc-Group" & @CRLF & _
"Show Name - Episode 01 - Ep Name" & @CRLF & _
"Show.Name.Part.3.Source.Quality.Etc-Group" & @CRLF & _
"Show.Name.Part.1.and.Part.2.Blah-Group" & @CRLF & _
"Deconstructed.E07.1080i.HDTV.DD5.1.MPEG2-TrollHD" & @CRLF & _
"Show.Name.E23.WEB-DL" & @CRLF & _
"Show.Name.E23-24.WEB-DL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")