package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(\[(?P<release_group>.+?)\][ ._-]*)?((\[|\().+?(\]|\))[ ._-]*)?(?P<series_name>.+?)[ ._-]+((épisode|episode|part)[ ._-]*)?((E)?(?P<ep_ab_num>\d{1,3}))[\(\)\[\] ._-]+((and.Part.|E)?(?P<extra_ab_ep_num>\d{1,3})[\(\)\[\] ._-]+)?(VOSTFR[\(\)\[\] ._-]*)?((par[ ._-]+Fansub-Resistance)[\(\)\[\] ._-]*)?(((v|V)([0-9]))[\(\)\[\] ._-]*)?(((8|10)(Bits|Bit))[\(\)\[\] ._-]*)?((?P<extra_info>((((FHD|HD|SD)[ ._-])?(\d{3,4}[xip*]+\d{0,4}))|(.*)))[\(\)\[\] ._-]*)?(VOSTFR[\(\)\[\] ._-]*)?((FHD|HD|SD)[\(\)\[\] ._-]*)?(((8|10)(Bits|Bit))[\(\)\[\] ._-]*)?(((v|V)(?P<version>[0-9]))[\(\)\[\] ._-]*)?((?P<crc>\w{8})[\(\)\[\] ._-]*)?.*`)
var str = `[Release-Group]_Series_Name_E100-E101_[VOSTFR]_[720p]_[HD]_[8bits]_[V3]_[13245678].mp4
[Kaerizaki-Fansub]_One_Piece_727_[VOSTFR][HD_1280x720][V2]_[1921E00C].mp4
[Titania-Fansub]_Fairy_Tail_269-280_[VOSTFR]_[720p]_[1921E00C].mp4
[ISLAND]One_Piece_726_[VOSTFR]_[V1]_[8bit]_[720p]_[2F7B3FA2].mp4
Naruto Shippuden 445 VOSTFR par Fansub-Resistance (1280*720) - version MQ
Dragon Ball Super 015 VOSTFR par Fansub-Resistance (1280x720) - HQ version
[Mystic.Z-Team].Dragon.Ball.Super.-.épisode.36.VOSTFR.720p
[Z-Team][DBSuper.pw] Dragon Ball Super - E028 (VOSTFR)(720p AAC)(MP4)
[SnF] Shokugeki no Souma - 24 VOSTFR [720p][41761760].mkv
[Y-F] Ao no Kanata no Four Rhythm - 03 Vostfr HD 8bits
Detective Conan 804 vostfr HD
Active Raid 04 vostfr [1080p]
Sekko Boys 04 vostfr [720p]
Show.Name.E23.Source.Quality.Etc-Group
Show Name - Episode 01 - Ep Name
Show.Name.Part.3.Source.Quality.Etc-Group
Show.Name.Part.1.and.Part.2.Blah-Group
Deconstructed.E07.1080i.HDTV.DD5.1.MPEG2-TrollHD
Show.Name.E23.WEB-DL
Show.Name.E23-24.WEB-DL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}