import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[(?P<release_group>.+?)\\][ ._-]*)?((\\[|\\().+?(\\]|\\))[ ._-]*)?(?P<series_name>.+?)[ ._-]+((épisode|episode|part)[ ._-]*)?((E)?(?P<ep_ab_num>\\d{1,3}))[\\(\\)\\[\\] ._-]+((and.Part.|E)?(?P<extra_ab_ep_num>\\d{1,3})[\\(\\)\\[\\] ._-]+)?(VOSTFR[\\(\\)\\[\\] ._-]*)?((par[ ._-]+Fansub-Resistance)[\\(\\)\\[\\] ._-]*)?(((v|V)([0-9]))[\\(\\)\\[\\] ._-]*)?(((8|10)(Bits|Bit))[\\(\\)\\[\\] ._-]*)?((?P<extra_info>((((FHD|HD|SD)[ ._-])?(\\d{3,4}[xip*]+\\d{0,4}))|(.*)))[\\(\\)\\[\\] ._-]*)?(VOSTFR[\\(\\)\\[\\] ._-]*)?((FHD|HD|SD)[\\(\\)\\[\\] ._-]*)?(((8|10)(Bits|Bit))[\\(\\)\\[\\] ._-]*)?(((v|V)(?P<version>[0-9]))[\\(\\)\\[\\] ._-]*)?((?P<crc>\\w{8})[\\(\\)\\[\\] ._-]*)?.*";
final String string = "[Release-Group]_Series_Name_E100-E101_[VOSTFR]_[720p]_[HD]_[8bits]_[V3]_[13245678].mp4\n"
+ "[Kaerizaki-Fansub]_One_Piece_727_[VOSTFR][HD_1280x720][V2]_[1921E00C].mp4\n"
+ "[Titania-Fansub]_Fairy_Tail_269-280_[VOSTFR]_[720p]_[1921E00C].mp4\n"
+ "[ISLAND]One_Piece_726_[VOSTFR]_[V1]_[8bit]_[720p]_[2F7B3FA2].mp4\n"
+ "Naruto Shippuden 445 VOSTFR par Fansub-Resistance (1280*720) - version MQ\n"
+ "Dragon Ball Super 015 VOSTFR par Fansub-Resistance (1280x720) - HQ version\n"
+ "[Mystic.Z-Team].Dragon.Ball.Super.-.épisode.36.VOSTFR.720p\n"
+ "[Z-Team][DBSuper.pw] Dragon Ball Super - E028 (VOSTFR)(720p AAC)(MP4)\n"
+ "[SnF] Shokugeki no Souma - 24 VOSTFR [720p][41761760].mkv\n"
+ "[Y-F] Ao no Kanata no Four Rhythm - 03 Vostfr HD 8bits\n"
+ "Detective Conan 804 vostfr HD\n"
+ "Active Raid 04 vostfr [1080p]\n"
+ "Sekko Boys 04 vostfr [720p]\n"
+ "Show.Name.E23.Source.Quality.Etc-Group\n"
+ "Show Name - Episode 01 - Ep Name\n"
+ "Show.Name.Part.3.Source.Quality.Etc-Group\n"
+ "Show.Name.Part.1.and.Part.2.Blah-Group\n"
+ "Deconstructed.E07.1080i.HDTV.DD5.1.MPEG2-TrollHD\n"
+ "Show.Name.E23.WEB-DL\n"
+ "Show.Name.E23-24.WEB-DL";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}