$re = '/\b(((https?|ftp|dict):\/\/|www\.)[^\'">\s]+\.[^\'">\s]+)(?=\s|$)(?!["<>])/i';
$str = 'my foobar http://www.google.com sfgsdg
my <a href="http://www.google.com">bla</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);