$re = '/div.*/';
$str = '[[ChromeDriver: chrome on MAC (345345345n5435345b34)] -> css selector: div[class=\'alert alert-danger\']]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);