package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x) # Allow comments in regex (ignore whitespace)
(?: # Repeat *
[^(|)]*+ # Match every char except ( ) or |
( # 1. Group 1
\( # Opening paren
(?: # chars inside:
[^()]++ # a. everything inside parens except nested parens
| # or
(?1) # b. nested parens (recurse group 1)
) #
\) # Until closing paren.
)?+ # (end of group 1)
)*+ #
\K # Keep text out of match
\| # Match a pipe`)
var str = `example|example (example(example))|example|example|example(example|example|example(example|example))|example`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}