$re = '/(?x) # Allow comments in regex (ignore whitespace)
(?: # Repeat *
[^(|)]*+ # Match every char except ( ) or |
( # 1. Group 1
\( # Opening paren
(?: # chars inside:
[^()]++ # a. everything inside parens except nested parens
| # or
(?1) # b. nested parens (recurse group 1)
) #
\) # Until closing paren.
)?+ # (end of group 1)
)*+ #
\K # Keep text out of match
\| # Match a pipe/';
$str = 'example|example (example(example))|example|example|example(example|example|example(example|example))|example';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;