import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x) # Allow comments in regex (ignore whitespace)\n"
+ "(?: # Repeat *\n"
+ " [^(|)]*+ # Match every char except ( ) or |\n"
+ " ( # 1. Group 1\n"
+ " \\( # Opening paren\n"
+ " (?: # chars inside:\n"
+ " [^()]++ # a. everything inside parens except nested parens\n"
+ " | # or\n"
+ " (?1) # b. nested parens (recurse group 1)\n"
+ " ) #\n"
+ " \\) # Until closing paren.\n"
+ " )?+ # (end of group 1)\n"
+ ")*+ #\n"
+ "\\K # Keep text out of match\n"
+ "\\| # Match a pipe";
final String string = "example|example (example(example))|example|example|example(example|example|example(example|example))|example";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}