using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3,}\s-\s(.+)(\.\w+)";
string input = @"01 - The Black Eyed Peas - The Time (Dirty Bit) - .webm
0000000 - Nelly Furtado - Say It Right -.webm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}