// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{3,}\s-\s(.+)(\.\w+)").unwrap();
let string = "01 - The Black Eyed Peas - The Time (Dirty Bit) - .webm
0000000 - Nelly Furtado - Say It Right -.webm";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}