$re = '/\d{3,}\s-\s(.+)(\.\w+)/m';
$str = '01 - The Black Eyed Peas - The Time (Dirty Bit) - .webm
0000000 - Nelly Furtado - Say It Right -.webm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);