#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(\S+)\b(?=.*?\b\1\b).*$"
Local $sString = "Cher Cher" & @CRLF & _
"Humphry Bogart Humphry Bogart" & @CRLF & _
"Edgar Allen Poe Edgar Allen Poe" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")