$re = '/\b(\S+)\b(?=.*?\b\1\b).*$/';
$str = 'Cher Cher
Humphry Bogart Humphry Bogart
Edgar Allen Poe Edgar Allen Poe
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);