re = /\b(\S+)\b(?=.*?\b\1\b).*$/
str = 'Cher Cher
Humphry Bogart Humphry Bogart
Edgar Allen Poe Edgar Allen Poe
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end