using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\S+)\b(?=.*?\b\1\b).*$";
string input = @"Cher Cher
Humphry Bogart Humphry Bogart
Edgar Allen Poe Edgar Allen Poe
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}