re = /\b(\S+)\b(?=.*?\b\1\b).*$/m
str = 'Cher Cher
Humphry Bogart Humphry Bogart
Edgar Allen Poe Edgar Allen Poe
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end