$re = '/\b(\S+)\b(?=.*?\b\1\b).*$/m';
$str = 'Cher Cher
Humphry Bogart Humphry Bogart
Edgar Allen Poe Edgar Allen Poe
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);