$re = '/(.+)\h+(?=\1)/m';
$str = 'Cher Cher
foo bar baz
Humphry Bogart Humphry Bogart
Edgar Allen Poe Edgar Allen Poe
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);