re = /(.+)\h+(?=\1)/m
str = 'Cher Cher
foo bar baz
Humphry Bogart Humphry Bogart
Edgar Allen Poe Edgar Allen Poe
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end