using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{1,5}?D";
string input = @"123456789D123456789";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}