$re = '/.{1,5}?D/';
$str = '123456789D123456789';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);