package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.{1,5}?D`)
var str = `123456789D123456789`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}