const regex = /(0|[1-9][0-9]?|[12][0-9][0-9]|3[0-5][0-9]|360)\°([0-5]?[0-9])?('|,|,)?\d+?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0|[1-9][0-9]?|[12][0-9][0-9]|3[0-5][0-9]|360)\\°([0-5]?[0-9])?(\'|,|,)?\\d+?', '')
const str = `255°15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}