re = /(0|[1-9][0-9]?|[12][0-9][0-9]|3[0-5][0-9]|360)\°([0-5]?[0-9])?('|,|,)?\d+?/
str = '255°15'
# Print the match result
str.match(re) do |match|
puts match.to_s
end