$re = '/(0|[1-9][0-9]?|[12][0-9][0-9]|3[0-5][0-9]|360)\°([0-5]?[0-9])?(\'|,|,)?\d+?/';
$str = '255°15';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);