use strict;
my $str = 'The%quick%brown%fox%jumps%over%the/lazy%dog.%%%';
my $regex = qr/(?<!%)%(?!%)/p;
my $subst = '/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";