import Foundation
let pattern = #"(?<!%)%(?!%)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"The%quick%brown%fox%jumps%over%the/lazy%dog.%%%"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)