re = /(?<!%)%(?!%)/
str = 'The%quick%brown%fox%jumps%over%the/lazy%dog.%%%'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result