const regex = /^([af][ .]?p[ .]?o|[Pp]*(OST|ost)*)\b\.*\s*[Oo0]*(ffice|FFICE)*\.*\s*[Bb][Oo0][Xx]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([af][ .]?p[ .]?o|[Pp]*(OST|ost)*)\\b\\.*\\s*[Oo0]*(ffice|FFICE)*\\.*\\s*[Bb][Oo0][Xx]', 'gmi')
const str = `APO box
FPO
A.p.o
F.P.O
APOPKO`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}