re = /^([af][ .]?p[ .]?o|[Pp]*(OST|ost)*)\b\.*\s*[Oo0]*(ffice|FFICE)*\.*\s*[Bb][Oo0][Xx]/mi
str = 'APO box
FPO
A.p.o
F.P.O
APOPKO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end