$re = '/(?:^|@).\K|\.[^@]*$(*SKIP)(*F)|.(?=.*?\.)/m';
$str = 'great@gmail.com
myemail@gmail.co.uk
test.test@gmail.com
test.test@gmail.co.uk';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;