import re
regex = re.compile(r"(?:^|@).\K|\.[^@]*$(*SKIP)(*F)|.(?=.*?\.)", flags=re.MULTILINE)
test_str = ("great@gmail.com\n"
"myemail@gmail.co.uk\n"
"test.test@gmail.com\n"
"test.test@gmail.co.uk")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)