re = /(?:^|@).\K|\.[^@]*$(*SKIP)(*F)|.(?=.*?\.)/m
str = 'great@gmail.com
myemail@gmail.co.uk
test.test@gmail.com
test.test@gmail.co.uk'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result