package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z](?:[a-zA-Z']*[a-zA-Z])?`)
var str = `'hello' world can't math'tjs'jvac a ' t gb '''dsf' 'df''' @#$khw@#$% sdfsdf'dsf'sdf'sdf jksk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}