re = /[a-zA-Z](?:[a-zA-Z']*[a-zA-Z])?/
str = '\'hello\' world can\'t math\'tjs\'jvac a \' t gb \'\'\'dsf\' \'df\'\'\' @#$khw@#$% sdfsdf\'dsf\'sdf\'sdf jksk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end