package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\/.*?\/.*)(\/)`)
var str = `/foo/bar/foo/bar/
/foo/bar/foo/bar/
/foo/bar/
/foo/bar/foo/bar///`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}