import re
regex = re.compile(r"(\/.*?\/.*)(\/)")
test_str = ("/foo/bar/foo/bar/\n"
"/foo/bar/foo/bar/\n"
"/foo/bar/\n"
"/foo/bar/foo/bar///")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)