package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(INV|inv)\d{5}$`)
var str = `INV12345
inv09806
asdfasdf
asd12344
inn12344
INV11111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}