$re = '/^(INV|inv)\d{5}$/m';
$str = 'INV12345
inv09806
asdfasdf
asd12344
inn12344
INV11111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);