re = /^(INV|inv)\d{5}$/m
str = 'INV12345
inv09806
asdfasdf
asd12344
inn12344
INV11111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end