#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<li>[^<>]*<strong>Downloads:<\/strong>\s*\K.*?(?=\s*<\/li>)"
Local $sString = "<ul>" & @CRLF & _
" <li>" & @CRLF & _
" <strong>Online:</strong>" & @CRLF & _
" 2/14/2010 3:40 AM" & @CRLF & _
" </li>" & @CRLF & _
" <li>" & @CRLF & _
" <strong>Hearing Impaired:</strong>" & @CRLF & _
" No" & @CRLF & _
" </li>" & @CRLF & _
" <li>" & @CRLF & _
" <strong>Downloads:</strong>" & @CRLF & _
" 3,840" & @CRLF & _
" </li>" & @CRLF & _
"</ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")