re = /<li>[^<>]*<strong>Downloads:<\/strong>\s*\K.*?(?=\s*<\/li>)/
str = '<ul>
<li>
<strong>Online:</strong>
2/14/2010 3:40 AM
</li>
<li>
<strong>Hearing Impaired:</strong>
No
</li>
<li>
<strong>Downloads:</strong>
3,840
</li>
</ul>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end