import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li>[^<>]*<strong>Downloads:<\\/strong>\\s*\\K.*?(?=\\s*<\\/li>)";
final String string = "<ul>\n"
+ " <li>\n"
+ " <strong>Online:</strong>\n"
+ " 2/14/2010 3:40 AM\n"
+ " </li>\n"
+ " <li>\n"
+ " <strong>Hearing Impaired:</strong>\n"
+ " No\n"
+ " </li>\n"
+ " <li>\n"
+ " <strong>Downloads:</strong>\n"
+ " 3,840\n"
+ " </li>\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}