package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(-\w+)*$`)
var str = `home-bird
home--dog
home-dog-bird
test--test-test
-another-test
tets-tets--sdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}