$re = '/^\w+(-\w+)*$/m';
$str = 'home-bird
home--dog
home-dog-bird
test--test-test
-another-test
tets-tets--sdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);