#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{1,3}[,\\.]?(\\d{1,2})?"
Local $sString = "3,50" & @CRLF & _
"450,41" & @CRLF & _
"6.00" & @CRLF & _
"6,00" & @CRLF & _
"35,000.00" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")