$re = '/\d{1,3}[,\\\\.]?(\\\\d{1,2})?/';
$str = '3,50
450,41
6.00
6,00
35,000.00
5
6
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);