import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,3}[,\\\\.]?(\\\\d{1,2})?";
final String string = "3,50\n"
+ "450,41\n"
+ "6.00\n"
+ "6,00\n"
+ "35,000.00\n"
+ "5\n"
+ "6\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}